Drone can't take off - Checkpoint 3

We are trying to fly the drone at Checkpoint 3 for position mode, and we cannot take off. We start the server on the jetson. we connect to QGC. Everything works. We flip the correct switches (before flight) and it all works. We get the 13 satellite connection. We connect to the GUI and everything is Green besides AT (assuming stands for AprilTags but unsure).

The problem is when we are trying to take off, and the drone just tries to flip over. In the GUI, we noticed that when we move the drone left, it rolls right and vice versa. So could be part of the problem. We have tried recalibrating everything, we tried redownloading everything via rerunning setup.py.

It seems in the GUI we are getting data via the MQTT Debugger screen - position, altitude, etc.

Any ideas what would make it so we can’t take off because it just flips over every time?

So you were able to successfully fly in Checkpoint 2?


If so, I’m suspecting something misconfigured or ESCs plugged in the wrong order. Can you run a motor test and let us know if the motor positions and rotations are what you expect as noted here:


I’m ruling calibration out given in your other thread you mentioned you’ve done that multiple times.

A screencast of what you’re observing with the rolling behavior would be helpful.

Solved… It was motors going the wrong direction. Thanks!