Can't connect to VRC GUI

Good evening,

My team is currently stuck on the software portion of the instructions. They were unable to connect to the QGC, but since it stated it wasn’t strictly required for anything, I had them skip it. They completed the next section consisting of the flight controller parameters. When they run the AVR GUI, they cannot connect to the MQTT, it just keeps showing failure.

I ran ifconfig to check the ipaddress of the jetson and confirmed it is

Everything else, other than the QGC and the AVR GUI has worked up until now. Are these two failures related?

How do we proceed from here?

Sounds like you are making progress! Can you confirm if you’re running the AVR software stack as discussed here:

Otherwise you won’t be able to connect with QGC or the GUI software. For example what happens when you run

./ run --min

Yes, we run ./ run

When we run the program, it creates all the modules and the status is done. It then loops through all the modules coninuously. I just made a video of it to pause it. A couple of things that I notice are:

mqtt_1 New Connection from on port 18830
mqtt_1 New client connected from172.18.0.6:50055 as auto-433

“waiting for avr/fusion//geo to be populated”.

“ValueErrot: No I2C device at address: 0x69
Cleaning up pins”
and then back to the loop

I can stop the loops by pressing Control C. I have then run ./ stop to delete the modules. When I rerun the python program everything loops the same again.

For the AVR software, It state that it is connecting to MQTT server at
Then I get ERROR - Connection failed to MQTT server
At the end, I get: socket.timeout: timed out

setup for the drone:

PCC connected to the Jetson
PCC has jumper on Featherwing for power
FC connected to computer
External monitor, keyboard, mouse

Not sure if anything needs to be changed.

Can you share the video you recorded here with the MQTT output? That would be really helpful.

Regarding the QGC issue can you run the following command to see if anything shows up in your terminal.

sudo cat /dev/ttyTHS1

More details can be found here:

I just ran sudo cat /dev/ttyTHS1 and I do get the gibberish/symbols continuously scrolling.

It will not allow me to upload a video. It states it is not an approved file type. Is there somewhere else I can upload this, or an email address to send it to?

A link to a YouTube video is likely the best way to upload a video to the forum.

Link to YouTube video for AVR Terminal

Thanks. It looks like this error is related to your thermal camera, which shouldn’t affect communication with the MQTT container. But to simplify things let’s try to isolate the problem. Run this command:

./ run mqtt

Here is my screen when running only that container and connecting with the GUI. Can you send us a screenshot of what your terminal looks like? Maybe we’re up against some sort of networking or firewall issue.

Once I was able to get it to create the new connection and connect the client. That process repeated over and over. I unplugged all of the cables to have the students practice flying, and all I get now is what is in the attached picture. It just hangs there.

I took the drone home with me to connect to my network o see if there may be an issue with network permissions or the firewall, and I was still unable to connect to the AVR GUI or the QGC.

Not really sure how to help these kids out. Competition is this Saturday, and they are unable to finish setting up the software.

I was finally able to get it to connect to the AVR GUI.