Drone not connecting in QGroundControl

We have multiple teams and they are all having the same problem.

They connect to the Jetson WiFi. Ssh into the Jetson and start the mqtt server. Then they go to QGroundControl and connect using the IP address. But QGC doesnt seem to connect to the drone. Anyone else having this problem? Did we miss something?

Thanks in advance!

1 Like

You say they started the MQTT server. Is the mavp2p server also running? That’s the software that bridges the connection from the Pixhawk telemetry cable, to QGC over WiFi.

A way to be sure, is to explicitly run ./start.py run mavp2p and then try to connect QGC. You don’t need the MQTT server to connect QGC.

Here is the output when we tried that command.

Are you connecting to the drone via hotspot or is the drone connected to your school’s network? What do your QGC connection settings look like? Here are mine that I use when connected to the drone’s hotspot:


1 Like

Thanks for the reply!

I am connecting to the drone via its network that it provides. We connect to the network. We ssh into the drone. We start the mqtt server and then go to QGC and try with the same settings you have and it doesnt connect. But as Nathan mentioned above, the mavp2p link seems to not be working correctly? I have the screenshot above with the output when we try the ‘./start.py run mavp2p’ command. Says there are a TON of errors in the output.

Hm, I’ve seen that before where it says “X errors in the last 5 seconds”. It’s very rare and we’ve never really been able to nail down what causes it.

Could you also try running ./start.py run mavp2p fcm as well and giving that a go? I’m wondering if it’s trying to route MAVLink packets to the non-existent fcm hostname, and that’s preventing QGC from connecting @droneblocks.

If that doesn’t work, I recommend running ./start.py stop --min so it stops and cleans up all the existing running modules, reboot the Jetson, and double check that the Pixhawk is getting power.

The good news at least is that don’t really need QGroundControl during flight, since the control GUI should have all relevant information you need, and that works with MQTT.

Ok, here is the output from the last command you asked to run, with the fcm at the end: mavp2p_fcm_output.txt - Google Drive

Here is the output from rerunning setup: rerunSetupOutput.txt - Google Drive

This is trying the run command AGAIN after rerunning setup for the like 5th time: startRunMinOutput10122.txt - Google Drive

It is just so weird all 3 of our teams are having the same problem here… ANY help/guidance/assistance would be GREATLY appreciated.

Oh I also forgot to mention that our pixhawk does seem to have power and there are 2 solid green lights and 2 blinking blue lights.

I’m not as familiar with the Pixhawk 6 this year, my guess with all the node appeared: chan=serial messages, there’s something wrong with the serial connection. @droneblocks do you have any advice.

I think Nathan may be right. It seems like something is not working with your telemetry cable. Here is a simple test you can run. Login to your VMC and obviously make sure your Pixhawk is powered up. Run the following command:

sudo cat /dev/ttyTHS1

You should see a bunch of jibberish printed out to the console. This is the serial port where Pixhawk communicated with the VMC. If you want more details on the how the mavp2p service is configured you can view the line here:

That data gets forwarded to port 5760, which is how your QGC connection should be configured. But please don’t mess with the configuration line above :slight_smile: It’s only for reference.

I recommend checking your telemetry cable and connections to your VMC. I speak from experience when saying it’s very easy to get your TX/RX lines flipped which will lead to no communication.

Keep us posted as we’d like to help you get this resolved!

Well, currently 1 of our 3 teams gets the gibberish from running that command. The other two dont. but the one that gets the gibberish still gets the error lines and still doesnt work, has those lines that say XXXX errors in 5 seconds…

Nevermind… it seemed to be a fluke? Isnt working for that team now…

We are trying to remake the telemetry cable right now.

We really need some additional assistance. We have now tried everything you suggested AND MORE. We have tried getting a new sd card and redoing ALL the firmware on the jetson from the ground up. They tried updating the firmware on the pixhawk. They tried making a new telemetry cable. They arent getting the gibberish from the pixhawk. One of the teams did actually get some gibberish but then tried to run ./setup and it wouldnt work still.

We really need some help fixing this issue. We are all very much out of ideas now.

It sounds like you feel confident in your hardware setup, which is good. Have you tried updating the params from this page?


That will be necessary to get the telemetry out of Pixhawk.


We didn’t add the parameters yet… The instructions are out of order. They say to run the software, connect to QGC and THEN do the parameters! So the kids didnt do that yet.

Up and running! Thank you all for your help @droneblocks & @nathan

@droneblocks / @nathan : it seems that it fixed that problem, but we are having yet another problem. We posted it in another thread: Drone can't take off - Checkpoint 3

Any help would be greatly appreciated!

Glad to hear that. Let me chat with the team as you do make a good point regarding order of content.

1 Like

How to participate in this competition. Please anyone help me

1 Like