BOSSA refuses to work

BOSSA refuses to run on macOS. On Windows 10 it does run, but a few seconds after starting the flash it crashes with no explanation. We followed all the procedures to a t. Have any of you had similar problems in the past, and if so, how did you fix it?

Screen Shot 2022-11-07 at 11.02.43 AM

I hope another team can chime in to help you. I don’t own a Mac, so I was never able to test it on that. I have tested BOSSA on a Windows 10 and 11 machine and had no problems.

I do remember running into that immediate crashing phenomenon when I first looked at BOSSA, but if I remember correctly, it was due to the PCC not being in the flashing mode, with the bright LED being solid green. I think forgetting the flash offset will corrupt your firmware, but BOSSA shouldn’t crash.

Another thing to try, have you tired some of the older releases? Releases · shumatech/BOSSA · GitHub

If that doesn’t work, let me know and I can try to walk you through flashing it a more manual way from the source code.

We had a mac, @Val can provide some more info.

1 Like

I tried to run BOSSA on a mac and it just didn’t work. MacOS on new M1 silicon doesn’t even have usb drivers and as for older macs they are not the same as Windows. I ended up having to use Windows in order to get it working. A solution I can think of is to sign up for a free trial of Parallels and run Windows 11 on your mac, then you can download the BOSSA.exe and use it that way. I haven’t tested this but it has worked with similar problems regarding USB game controllers.


Good call-out. I had put that in the competition requirements section at the beginning of the documentation that we don’t support the new M1 silicone.

1 Like