VMC Not Turning On (but it is receiving power)


Our Jetson has been working fine for a while, but just yesterday it stopped turning on. We detached all usb devices, and tried with both the barrel jack and micro usb power. Both times, the fan spins momentarily, but doesn’t light up.

With the exact same steps, I borrowed another Jetson and it booted properly.

Is this a software issue that I can solve by reflashing the sd, or something else entirely?

Update: I swapped the SD card with that of a working Jetson, and it still wouldn’t turn on.


Our team faced the exact same issue before the competition, although the fan in our Jetson would turn on for an even smaller duration compared to the video you attached.

We tried many things but ultimately concluded that this is not a software issue, but instead seems to be hardware related.
Someone in our team plugged out one wire that was going to the Jetson and it turned on, and we still do not know why or how. It seems to us that there was potentially some kind of short circuit somewhere which was preventing this.

But after about a month or so, the same issue resurfaced and we tried everything we could think of (both hardware and software related) but then eventually switched out the Jetson as we could not get it to work.

I would recommend that you try to look into the hardware that goes to/from the Jetson, and if you do end up finding what causes this please do let us know as well.

Hope I was some help.

This is definitely a hardware issue and not a software issue.

The Jetsons tend to be temperamental, so it’s hard to say for certain what exactly is causing the issue. I recommend unplugging everything except for the power cable, and test if that works. I would try both the barrel connector (that came with the Jetson), and the microUSB cable. You can also try removing the compute module from the carrier board, reseating the microSD card, and reseating the compute module.

If that doesn’t work, the Jetson is likely dead. Something as simple as an electric shock, a grounding issue, or accidentally using the wrong power connector can be enough to kill it.

If this is a hardware issue that requires a replacement; does Bell provide replacements during the off-season?

Sorry to hear that you’re running into issues with the Jetson Nano. We saw this a handful of times last season. REC will be making an announcement soon on how replacement parts will be handled this season, but in the meantime, you can send an email to BellAVR@roboticseducation.org for more details.

Will do. Sad to hear that it might just be dead, I’ll send out an email. In the mean time, I’m lucky enough to be at a school with two drones so I can keep chugging with development.

I want to keep working on this VMC as long as I can, with a bit of tinkering since posting this I managed to get it to boot for a solid 10 seconds (green light on, but not long enough for the fan to start spinning).