Jetson randomly not turning on properly

2 days ago, my team and I were practicing quite a bit with the AVR drone on our practice field to see how fast we could clear phase 1. Our first 2 runs went according to plan. We had some issues where the laser just wouldn’t work and we’ve had this issue for a while so we just power-cycled and it worked fine after that. On our 3rd run the drone just didn’t give out it’s wifi signal or start any of the MQTT services. We power-cycled and tried again and it still didn’t work. After plugging in the Jetson via HDM we were prompted with the NVIDIA screen and nothing else. We were stumped so we left the robotics building and came back today. We plugged in a new battery and everything was working properly again. Does anyone have any ideas as to why this might have happened?

Maybe we can help you diagnose as it’s hard to say what’s going on. If you can boot into your Nano and run the following:

journalctl -k

You will hopefully get the previous boot log. But I realize you may be a couple boots beyond when the error happened. Another thing to check would be the syslog:

less /var/log/syslog

Everything should be dated in there. Your Nano may archive these files and you should be able to access a previous one:

ls -l /var/log/syslog*

On my Nano this shows the following:

-rw-r----- 1 syslog adm  22187 Nov 21 00:09 /var/log/syslog.1
-rw-r----- 1 syslog adm  56325 Nov 20 11:31 /var/log/syslog.2.gz
-rw-r----- 1 syslog adm  15545 Oct 11 00:05 /var/log/syslog.3.gz
-rw-r----- 1 syslog adm  91761 Oct 10 09:11 /var/log/syslog.4.gz

You can use the same less command to look in the gzip files as well:

less /var/log/syslog.2.gz

BTW I’m doing this on my non-AVR Nano so I’m not 100% sure if the image is the same as the AVR one. Let us know what you uncover. Very interested in hearing what you find out.

Go with what @droneblocks suggests first here, but I wonder if it’s an SD card issue. Usually the Nvidia splash screen and nothing else is indicative of a missing boot device, if I remember correctly.

That’s what we thought too, but when we put the sd card in another Jetson, it booted properly.