Debugging PCC (LED, Gimbal, ZED)

  1. LED and LED status bar somewhat working

PCC doesn’t seem to be sending signals to the LED and the status bar, it looks like the jetson is sending signals to the PCC because the red led flashes when we do something on the AVR GUI. There is this weird occurrence when we hit the laser on button ( Thermal view/control tab in AVR GUI) the LED strip flashes for a quick second. Also it seems like when we want to fire the laser, the buttons seem to be working backwards because when we hit the (turn off button) it fires the laser.

  1. Gimbal not responding to input from manual joystick(AVR GUI)
  • We have all of the gimbal wires connected to the right ports and it seems like it receive input from the PCC because when we go onto the VMC Controls in the GUL and hit the close and open for servo 3 and 4 they move. We don’t know where the problem stems from because the PCC board is working fine, we also flashed it to see if that was the problem and it seems like it didn’t work.*

3.ZED camera doesn’t seem to connect to the jetson

  • when we run the ./ run vio it tell us that the connection has fail, which is weird because we have the ZED connected to the jetson via cable.

Thank you in advanced

What cable are you using for the ZED? While it might look like a standard USB - C cable, it’s not.

If you’re trying to use a third party cable, give it a test using the provided cable and then try

I’m using the cable that came with the ZED.

when it’s powered, does the light on the front of the ZED turn on? The cable is orientation sensitive

1 Like

Well I didn’t know about the cable being orientation sensitive. When I put in the right direction the light didn’t turn on. I’m guessing that the zed is faulty because I connected the cable to the a wall outlet and it didn’t turn on either. :smiling_face_with_tear:

1 Like


I think I might have been wrong about the light. I thought it would turn on when powered, but it’s possible that it only turns on once it is transmitting data. Once you have the orientation right, plug it into the VMC and try running (./scripts/ then

LETTS GO, it worked thank you for your help. Maybe you can help me out what does fcm stand for? And how do I make it turn on, because right now it’s red on the GUI? I ran the ./ run fcm and it give me errors saying something in line 800 ish isn’t there.

FCM stands for Flight Control Module, as it talks to the Flight Control Computer (the Pixhawk).

If you can copy-paste or screenshot the output I can probably figure out what’s wrong.

For some reason, it’s failing to connect to the MQTT server. @bhanner-bell since you still work on the 2022 repos, do you have any ideas?