The Motors on Our drone won't spin

Hello, the 2 CW and 2 CCW motors won’t spin on our drone. I was wondering if it was maybe an ESC problem but after I checked our ESC is calibrated. The Flight modes, radio, sensors, and airframe are all properly calibrated as well. I’m kind of stumped here, any suggestions?

Hey @GR21,

When you say the motors wont spin, are you trying to arm the drone to test? Have you performed a motor test within QGroundControl? Do the ESCs make a noise when you power up the drone?

We need some more context about where you are in the build process and what you’re attempting to do when the motors dont spin.

I am at checkpoint 1. The ESC does make noises and I have checked my connections with the ESC multiple times. I tried running a motor test on the QGroundControl app and nothing happened when I moved the various sliders. I flip the arming switch on the controller and only 3 of the 4 motors spin. I’ve calibrated the Airframe, Sensors, Radio, Flight Modes, Arming, Kill switch, and the Power. I stopped after I could not test my motors.

We’re having a nearly identical issue with ours. We’re only getting two to spin. We think we have a faulty ESC. We have emailed for a replacement but have not received a response.

Are you guys using the replacement ESC? We had a configuration issue with the first batch. See the note here

We also have an issue where only one motor doesn’t spin. When we arm and spin all but motor 3 spins.

We were told that our ESC is the new one since our shipment arrived later and it came with the motors that have the Bell AVR logo on them.

Is there any way to identify the correct ESC?

We received a new ESC. We replaced it and the problem is still there. We are at a loss for what to try now. Any advice on what could be the problem?

Okay here is how I would tackle this:

There is a chain of components that spans from the flight controller all the way down to your motors.

We need to isolate each component and determine where the breakdown is.

The first thing I would check is my cabling, especially the ones I made myself. Do the pins on one side of the FC-ESC harness have continuity with their corresponding pins on the other? Do you have any pins that have continuity that shouldn’t? Once you are confident about your wiring, head to the next step.

Now lets check that the cables are plugged into the right place. Does esc output 1 connect to motor input 1 on the ESC? Do this for all connections.

If you still get 3/4 spinning, start swapping the FC to ESC ordering (plug the non-functioning motor into a known functioning motor’s port). Does the motor now spin? If it does, odds are you have a bad wire or connection (or potentially broken channel on your ESC but while this IS possible, its not likely). If it still doesn’t spin, you can rule out the FC from the chain and work your way down.

I would then swap the motor outputs. Again, put a non-functioning motor on a functioning motors output and see if it spins. If it does then you can rule the motor out, and focus your efforts on your ESC and wiring.

That being said, I’d like to avoid dog piling on one support thread. While its possible you may have the same issue as OP, its likely that your situation is slightly different and so you should make your own thread so we can support your specific case. That being said if you’re all from the same team, and therefore dealing with the issue on the same drone, feel free to chime in on the same thread.


I’ve made a new post for myself.

Here is an update for some more troubleshooting steps:

If you get all 5 beeps, its likely that your ESC is fine but misconfigured or out of calibration.