Motor 3 not spinning


We are having some problems with our drone. One of our motors on our drone is not spinning and we have tried to implement the following solutions:

  1. We have done ESC calibrations.
  2. We have checked cable continuity.
  3. We have switched PWMs and PWM I/O cabling.
  4. We have switched the motors on each port and it will spin unless on port 4 of the PWM.
  5. We got a new ESC.
  6. We have reinstalled firmware and recalibrated sensors.
  7. We watched the ESC troubleshooting video with the beeps. The motors on ports 1-3 will complete all 5 beeps.

This has let us to believe that it is a problem with the FC. If you have any input on solutions please let us know ASAP. Otherwise we will order a new flight controller.

Thank you for your time!

See this other post about motors not spinning: 2/4 Motors not spinning - Technical Support (Official) / AVR Drone Software - Bell AVR Forum

Let us know if any of this helps. Also please provide troubleshooting info back to us as you work through the problem.

Yes, we’ve already performed the troubleshooting described in that post.

Help! Still not working. I didn’t see a FC as a replacement option. How can we get one?

We sent an email to Would appreciate your response!

Solution was new FC. PWM controller on old FC looks fried.