Remote Development SSH tool not working

I am trying to connect to my drone through vs-code. However, every time I try and ssh into the drone I get an error.
Link to google drive with screenshots:

Resulting screenshot(error1 on the google drive)

I run this command to try and ssh into the drone through vscode.
(error2 on the google drive)

Then I get this popup, I select the first option
(error3 on the google drive)

Once I click it, another popup opens on the bottom right, I click ‘connect’
(error4 on the google drive)

After I click the connect button, my computer opens up a new vs code window. I select Linux as my operating system
(error5 on the google drive)

Finally I get the same error as I stated in the beginning
(error6 on the google drive)

However I can still connect to the jetson through CMD
(error7 on the google drive)

Do you any ideas of what I’m doing wrong?

Sorry about using google drive links, the forum only allows me to use one screenshot

Thanks for reading and helping!

That’s interesting that you can ssh in, but not use VS Code at the same time. Try following these steps: Connecting to the Jetson | Bell AVR Documentation

This will reset the SSH key and may fix the problem/

Thanks for responding to this thread. I tried restarting my SSH key but I still get the error.
Thanks for reading and helping!

Ah, looking at this thread, I think the problem is that the Jetson does not have internet access (since VS Code has to download its server software).

Option A: Connect the Jetson to the internet via ethernet, and then set everything up once.
Option B: Try to follow these instructions: visual studio code - Using "Remote SSH" in VSCode on a target machine that only allows inbound SSH connections - Stack Overflow
Option C: Abandon VS Code, and edit on-device with a command line editor like vim or nano.

We should definitely update the documentation @nholowskobell to call out this limitation.

Sorry for taking a long time to respond. I tried to use another solution with FileZilla and updating the sandbox through it. However I soon ran into a issue, I cant build without the jetson Wi-Fi. As of now I’m trying to connect the jetson again through Wi-Fi with the serial. I get errors saying that my SSID doesn’t exist. I believe I am typing the SSID and password correctly because I’m copying and pasting it through windows settings to try and eliminate any chance for me to misspell it. I was wondering if I could have some helping connect the jetson with ethernet. I try plugging in my ethernet to the jetson but I don’t know what I’m doing. Is there any chance you can give me instruction on how to connect the jetson with Wi-Fi through a ethernet.

Thanks for reading!

Sorry I missed this reply.

First off, if it says the SSID doesn’t exist, you can run sudo nmcli device wifi list to see a list of all the WiFi networks the Jetson sees. I’m not sure if the WiFi card supports 5GHz networks, so that could be the issue.

If you plug in an ethernet cable, do you have an internet connection? You can check to see if the Jetson has an IP address by running ifconfig eth0. Additionally, you can try to ping something like: ping -c 4`.

Lastly, as an alternative to transferring files with FileZilla/WinSCP, you can also edit code directly on the Jetson. You can download VS Code if you want, or use a command line editor such as nano. There’s a number of options, without needing to use another computer.