Jetson wifi errors

Our jetson wifi network does not have internet, so we cannot connect the AVR GUI or QGC wirelessly. The network shows up on our computer and we can connect to it but when we do, the network says “connected, no internet”. We tried recreating the wifi network multiple times but there is still no internet from the jetson. Has anyone run into this issue?

That’s correct. Your Jetson (aka VMC) won’t be able to get out to the internet, but will be in hotspot mode. This means your computer and the VMC will be on the same local network. This is similar to when your computer connects to a home or school network. The only difference is that the VMC does not have access to the outside net, which is not necessary once you have everything configured.

With that being said, after you are connected to the VMC’s hotspot you should SSH into the VMC with the following command:

ssh  avr@

This assumes avr is the username you have setup for your VMC. Then you’ll need to start the VMC software as discussed here:

and finally you should be able to connect over the local wireless network (your computer to the drone) using QGC as explained here:

and the AVR GUI as explained here:

I hope this helps and let us know if you run into any other problems!

1 Like

We are having a similar issue with the Jetson being its own hotspot. Our issue is that PuTTy and Windows Power Shell both give timed out errors when attempting to connect via SSH. We have checked to make sure the ip address shows up as but it refuses to connect

What happens when you connect to the AVR hotspot and run:


Do you get a reply?

Well, we got it connected through PuTTy but QGroundControl and the AVRGUI do not connect.

Did you start the AVR software first? To me, it sounds like if you can connect with PuTTy, you don’t have any network issues. The MQTT server on port 18830 is required for the AVR GUI, and mavp2p with port 5760 is required for QGroundControl