QGroundControl updates firmware, but wont display the "Summary tab"

We plugged QGC into the FC with USB-C, and after a successful firmware update, QGC wont prompt us with the summary tab like the AVR docs say it should. We have tried it with and without the battery plugged in, and we have tried the setup in different orders (like being in the summary tab before we connect, etc.) If it helps at all, the home page of QGC says “Disconnected” at the top left no matter what we try.

Hey Karatekid38, I’m sorry to hear that you’re facing this issue. I want to make sure if you are using the “daily build” version for QGroundControl. It should say “QGroundControl Daily” at the top left corner of the application.

Thanks for the response, I went through the docs again and followed the download process once more, and now GQC says “Daily” at the top left, thanks for the help!

You’re welcome! Are you able to connect the drone to QGroundControl now and view the summary tab?

Yes, it works great now!