FC not connecting to q ground control

If anyone could help us with this problem it would be great. I am trying to use the USB c cord to plug into the pixhawk and our laptop to flash the firmware. When I plug it in, Q Ground Control doesn’t connect to it. It isn’t the cable as I have tested 4 different ones. It also isn’t the laptop as I tried two. I used the console and log reporting to know that windows recognizes that something is plugged in, but Q Ground Control doesn’t. Any solution?

Hey Jackson, I ran into this problem a while back when working through my build. One thing that you need to make certain of is that you are downloading a daily build and not the one labeled Stable Version 4.0. You can go to the docs page here:

and click on the download link. It will take you to the QGC daily build page. Let us know if that doesn’t do the trick.


Ok, i’ll try that on monday. I was just using the version from last year.

1 Like

I’d also like to re-iterate what Dennis suggested. The Pixhawk 6 is still very new, so it requires a very recent version of QGroundControl in order to flash and connect to.

Worked thanks! It wont let me post unless its 20 characters so this is just spam