Motors turn with QGC but not Controller

When we run the motor test on QGC, all four motors turn like they should. However, when we try arming/disarming with the remote control, we can’t get the motors to turn. We have gone through all the Flight Controller Setup instructions, wondering if anybody could help.

In QGC do you see a green “Ready to Fly” in the top left of the screen?

and when you arm with your radio do you see:

Generally, if you try to arm and it doesn’t then there’s a setup issue. QGC will normally complain and tell you the reason in a yellow warning box.

Also, I’m assuming you’ve done the QGC radio calibration and setup your flight modes.

We have a “ready to fly” dialogue, but never an armed dialogue. We have now tried two different controllers and have programmed them both.
Whenever we go to the “Flight Modes” tab, it never shows that it is armed, but when I hit the kill button, it highlights yellow, showing that it is killed. We have tried two different controllers and they both do the same thing.

There must be a problem with that switch. We changed the arming switch to Channel 7 and it works.

Very strange, but glad to hear you got it working.