ESC Calibration Issue

We’re trying to calibrate the ESC, and Qgroundcontrol is giving a battery emergency error, and it’s not making the sound sequence that it should during calibration. We then test the motors and there’s no power going to the motors.

Hey @Zshaffer,

Can you tell us the voltage of your battery as measured by a multimeter?

Can you then show us the battery voltage as reported by QGroundControl?


Multimeter gives us 16.8V

And here’s a screenshot of QGroundControl:

Could it be that your cell full voltage is too low? 16.8v should definitely not cause a battery emergency otherwise. The Full Voltage (per cell) should be 4.2v

We figured out that two of the wires were backwards from the esc to the fc.

1 Like

Did resolving the wires solve your problem?

It fixed this problem, but now we’re on to only one of the motors getting power.

Are you using the updated ESC? See the note here.

We are using the new one. We think it might be bad. We’ve plugged another motor into the cables that powered the motor that seemed to be working, and the other motor powered up fine. So it seems like the ESC might be bad.

Please see my post here and let me know what the outcome of that testing is.

We verified each of the motors work, but only one set of connections from the ESC will push any power to the motors. We checked every combination with a multimeter as well, and the ESC is only pushing power to one set of motor wires.

Did you try re-ordering the outputs from the FC to the ESC to make sure the pwm is flowing out of the FC to a known functioning channel on the ESC?

Other than that, pictures might help us understand what’s going on.

Please take a look at this video. Do all of your motors make the full 5 beeps? If so, your ESC is likely fine and may need calibration.

We ran through the first part of the video, and the front right motor didn’t beep. We resodered the connections to see if that fixed it, and it still didn’t beep. We still get a beep and power to motor 3 when we plug all of the wires in.