Drone Wont Take off

Hello, we attempted to fly our drone but no matter how much throttle we give it, it wont take off. We tried switching the motors many times but only one propeller goes to only one motor and the propellers can only go a certain way with them sloping toward the middle of the drone.Any help is greatly appreciated.

Can you please provide more insight on your prop-motor issues? Could you post a top down picture of your drone and indicate the direction each one of them spins?

We are having a similar problem. It will not trottle up enough to take off.

@drake.knapp please make your own thread with the specific steps you’ve tried. Thanks

So we just switched the polarity of the motors and it worked

We are having similar problems. Without the Propellers on it spins up and slows down after a second. With the propellers on it won’t take off.

Would you mind posting a quick video of the behavior? We’d like to see the motor/prop rotations and observe the sounds of the motors. You can upload to YouTube, Dropbox, Google Drive or whatever you prefer. Also, please open a new forum topic as it will make it easier for us to help troubleshoot. Thanks.