AVRGUI not displaying telemetry

https://pastebin.com/Ntx67JbL - FCM error code

I’ve been having a weird issue recently where my AVRGUI isn’t displaying any of its telemetry data, despite said data clearly existing as shown in the message debugger. I’ve triple checked all the wiring, and the FCM is absolutely connected (as shown by the message debugger) and I ran setup.py and start.py right before this test. I don’t know what’s causing the FCM error code in the pastebin above.

The pastebin link you sent definitely shows the flight control module being unable to connect to the MQTT server. It looks like it was not running, as the connection was refused.

As for the GUI, was there any output to the console? You’re using the GUI from the AVR-2022 repo, correct?

1 Like

I am indeed using the GUI from the 2022 repo. Is there a new build for 2023?

I don’t know why the FCM can’t connect to the server, and I’ve reset basically everything to the Bell AVR standard software. I pulled from the github repo recently, ran setup.py, and even tried swapping out the jetson.

I’d appreciate any insight you have on what could be causing the connection issue, and whether it’s a hardware or a software thing.

You should be using the 2022 one, 2023 is not backwards compatible.

What happens if you just run the mavp2p, mqtt and fcm modules? Also re-run the setup.py script so that the latest version of the containers are pulled.

@droneblocks any idea? I’m not sure on this one.

1 Like

Ok. Update.

I re-ran setup.py, no errors.

I did ./start.py run mavp2p mqtt fcm

Same error as last time, gathering future exception. I tried checking the dockers while start.py is running, and this is what showed:

3bf4784931ac Package avr/2022/fcm · GitHub “/bin/bash -l -c ./e…” 33 seconds ago Up 32 seconds avr-2022_fcm_1
3222848a1b03 Package avr/2022/mavp2p · GitHub “/app/mavp2p serial:…” 34 seconds ago Up 32 seconds>5760/tcp, :::5760->5760/tcp avr-2022_mavp2p_1
d2a8454c07ee Package avr/2022/mqtt · GitHub “/docker-entrypoint.…” 34 seconds ago Up 32 seconds 1883/tcp,>18830/tcp, :::18830->18830/tcp avr-2022_mqtt_1

So the mqtt server seems to be running, I’m just not sure why the fcm can’t access it

Update again.

I’ve tried basically every combination of scripts to launch the fcm module.

Is it possible that there’s a hardware issue with connecting to the flight controller? We’ve checked most of the wires with a multimeter already, but I don’t really have another explanation at this point.

Update #3.

I tried reflashing the pixhawk, and ran setup.py again for good measure. Still getting the same error.

Without the flight control module, I can’t enter position hold flight mode.

Is there a way to completely scrub everything off of the jetson so that it perfectly mirrors the github? I’m worried there’s some error that isn’t getting overwritten when I do setup. I also may just be losing it after being at this error for three weeks.

If you have the time and no other obvious solutions, try re-flashing the Jetson. It has helped fix issues in the past for me

Will do! Thanks!
Post must be at least 20 characters

1 Like