Zed camera shows up via lsusb, but setup.py won't detect it

lsusb reveals that our Jetson sees the Zed camera plugged in.

ID: 2b03:f681

but when running setup.py, we can never get past the Zed step.
Also setup.py seems to knock the wifi out pretty reliably.

We have not yet run setup.py successfully the first time. This is a showstopper.

Read the code for setup.py and saw the --dev command flag that’d let setup proceed past the Zed step.

Running that now so that we can at least set up other elements like the gimbal and such.
Going to need an answer about this ASAP though.
Suspect issues with Docker because it seems to be Docker that’s torching the Jetson’s wifi.

In case it’s relevant to Docker and wifi, we damaged this year’s Jetson WiFi card, so we installed the Jetson WiFi card from last years VRC/AVR competition.

The wifi is now gone and the card doesn’t show up in lspci…

Hey @tkiesel I don’t think we’re doing anything with Docker that should interfere with WiFi. Would you happen to have a spare micro SD card lying around? It sounds like we don’t know that the hardware is 100% operational and one suggestion I would have for that would be to flash a different SD Card with the vanilla Jetson SD Card image and see if you can get a successful wifi connection. That would help isolate enough variables to see if your issues are purely hardware or software related.

If you can get the wifi (or really just internet) issues sorted, id recommend you double check that your git repo with the AVR software is on the main branch and up-to-date and try re-running the setup.py.

Other than that I’d have to defer to @nathan for more insights.

@bhanner-bell & @nathan

Thanks for the info. I used a vanilla Jetson image and verified that neither this year’s Jetson Nano nor last year’s Jetson nano are addressing the wifi card. Identical
dmesg | grep “tegra-pcie”
outputs on both Jetsons and on both SSD images on those Jetsons, so I think our wifi card is toast.

What are the emergency options to procure a new wifi card?

Well, you can try bellavr@recfoundation.org, but we are within day(s) of the next competition so I would assume amazon (this one shows it can be delivered tomorrow :frowning: ) or maybe a usb wifi card from Best Buy would be faster.

If you are competing at Arlington this weekend, we may have some at the support booth.

I’ll pick up the USB model at Best Buy today, and we’ll hope there’s a free NVME card at the support booth in Arlington on Saturday ( for the better reception! )


I was travelling all day today to the DC competition.

@bhanner-bell is correct, the setup.py does not do anything related to the network, so I agree it’s a hardware problem.

I’ve used one of these myself with my Jetson and it works. The reception isn’t great, but it’s functional.

As for why the Zed camera doesn’t show up, that’s hard to diagnose. Are you using the cable that came with the Zed camera? Other cables we’ve found generally don’t work. Otherwise, I recommend trying other USB ports and plugging it in/unplugging it a few times.

The --dev flag is definitely not ideal, since it builds all the software the hard way, rather than downloading our pre-made images. You could potentially comment out line 281 AVR-2022/setup.py at 329fefedd4a1e81b80905d9ce0a64b7996ff5ae6 · bellflight/AVR-2022 · GitHub to bypass this check for now.

We ran into this exact same problem. I can almost guarantee you it is the cable, it has nothing to do with the software most likely. Make sure you are using a USB 3.0 cable to connect the ZED to the Jetson. It’s supplied with a 2.0 which does not work. The instant we made the upgrade it worked.


The real solution to this was very frustrating when we figured it out. It turns out that the USB C end of the cable only works with one orientation. You should see a symbol on one side and that needs to face out.

We’ve tried the Zed cable, and knew about the orientation. It doesn’t work (despite the hardware clearly being visible in lsusb )

@Tig Will try your suggestion. I’ve tried every USB-C cable I or my kiddos have incl. my own phone charging cable, and the blue usb-c that are used for charging the Sphero RVR. No dice on any cabling so far, but I’ll see if I can Best Buy a cable tonight.

@bhanner-bell I picked up that ASUS part on my way home last night, but sadly there are no drivers for it on the Jetson Nano. I’m hoping that you all have a Jetson Wifi card there tomorrow!

@tkiesel bummer. I’m sorry the Best Buy one didn’t work out. Linux support for WiFi dongles can definitely be hit or miss.

I have inquired about setting aside a WiFi card for you tomorrow in Arlington.

When you get to Noel (@nbrownback-bell) at the support booth, just tell him that Casey sent you for the WiFi card.

1 Like

Thanks so much @bhanner-bell !!